Another word on namespaces

Kent Frederic’s recent post about Dist::Zilla minting profiles was a great overview of the subject, but because I try to follow best practices, I was struck by the section “A word on namespaces.”

Kent recommends that if you’re making an author pluginbundle, you should name it Dist::Zilla::PluginBundle::Author::$CPANID. This extra bit of namespacing makes life easier for many people in many ways. I was immediately convinced that he was right, and moved my author stuff into appropriate author namespaces.